NEW USER - Problems with FCB1010 mapping Cubase 5


montesarchiopietro@...
 

Hello everyone.
I am new to this group and I'm glad to join this FCB1010 community. I bought my FCB1010 last month, and I'm trying to map it with Cubase 5. The problem is that when I try to do it with the generic remote device control, every time I press a pedal with midi learn it always brings it to "Prog. Change - MIDI Ch. 1 - Address 0", the same for each pedal, even if I set different CCs manually for each preset. Of course sending all the messages to Address 0, the pedalboard doesn't communicate with Cubase and doesn't do the things I want to do (basically for me, mute and unmute the different midi channels). The FCB1010 is linked to the computer with a cable midi in/out - usb. Can you help me with this? Thank you in advance!


Chris Astles
 

It's been a while since I've had my unit in factory settings, but I believe that "out of the box" all of the presets send a PC message on address 0. This video https://www.youtube.com/watch?v=SYNND5nMWhc&t=790s explains perfectly how to assign the addresses of the PC messages.

Hope this helps.


On Mon, 14 Dec 2020, 11:13 , <montesarchiopietro@...> wrote:
Hello everyone.
I am new to this group and I'm glad to join this FCB1010 community. I bought my FCB1010 last month, and I'm trying to map it with Cubase 5. The problem is that when I try to do it with the generic remote device control, every time I press a pedal with midi learn it always brings it to "Prog. Change - MIDI Ch. 1 - Address 0", the same for each pedal, even if I set different CCs manually for each preset. Of course sending all the messages to Address 0, the pedalboard doesn't communicate with Cubase and doesn't do the things I want to do (basically for me, mute and unmute the different midi channels). The FCB1010 is linked to the computer with a cable midi in/out - usb. Can you help me with this? Thank you in advance!


Chris Astles
 

Just to clarify, each preset sends a customisable combination of PC and CC messages.

If you want the response to be "Prog. Change - MIDI Ch. 1 - Address <something different>", then use the above link to change the PC messages.

If you want Cubase to respond to your CC messages, I'm not too sure specifically about Cubase, but in my DAW CC messages are only "listened to" by virtual instruments.

On Mon, 14 Dec 2020 at 11:28, Chris Astles <cjastles@...> wrote:
It's been a while since I've had my unit in factory settings, but I believe that "out of the box" all of the presets send a PC message on address 0. This video https://www.youtube.com/watch?v=SYNND5nMWhc&t=790s explains perfectly how to assign the addresses of the PC messages.

Hope this helps.


On Mon, 14 Dec 2020, 11:13 , <montesarchiopietro@...> wrote:
Hello everyone.
I am new to this group and I'm glad to join this FCB1010 community. I bought my FCB1010 last month, and I'm trying to map it with Cubase 5. The problem is that when I try to do it with the generic remote device control, every time I press a pedal with midi learn it always brings it to "Prog. Change - MIDI Ch. 1 - Address 0", the same for each pedal, even if I set different CCs manually for each preset. Of course sending all the messages to Address 0, the pedalboard doesn't communicate with Cubase and doesn't do the things I want to do (basically for me, mute and unmute the different midi channels). The FCB1010 is linked to the computer with a cable midi in/out - usb. Can you help me with this? Thank you in advance!


montesarchiopietro@...
 

Yes, I can confirm that at the first try the unit was in the factory setting. Then I changed the PC messages with different numbers for each pedal, but again the result from the midi learn was always the same, with address 0 for any pedal. 


rmilby@...
 

I'm a newb as well, I feel your pain.

You said "I changed the PC messages with different numbers" but the MIDI learn function is usually reliable - so I suspect that you have not saved the changes by doing  "Exit PRESET programming mode through keeping the DOWN/ESCAPE key"
for a few seconds" as in "2.4.2 Programming switches" in the manual.


It seem a long press of
the DOWN/ESCAPE key is required after any change.

Please remember that I am new, and Ms. CJA and others in this group are far more reliable than I.

Oh, here is a video that the user Steve Beukema made just so he could remember ONE basic programming task
  https://www.youtube.com/watch?v=EIcCRHLwDJE
I found it helpful, and some reassurance that I am not the first person to struggle with this.
Good Luck, let us know if you resolve this.
-Rob


EJ SHELDON
 

Welcome New User!
 
First some info/advice.
 
1) How do you KNOW that your changes took?
You need a MIDI MONITOR. MIDIOX is full featured and FREE:
 
http://www.midiox.com/
 
2) Forget manual programming it's a PITA. Use an editor. This one is FREE:
 
http://www2.mtnsys.com:81/faq-fcb/PCEditorBeta.htm
 
3) However, unless you read HEX, it's MIDI MONITOR won't be much help. Plus, it's ancient and unsupported. This is THE BEST, works with the stock chip as well as the UNO chip, and has usable MIDI MONITOR. It's NOT FREE. Costs <>$22. WORTH EVERY PENNY!
 
https://www.fcb1010.uno/
 
Now to your problem.
 
Most DAWS "listen" on channel 1. When using "Learn" they "hear" the first message received. The FCB sends it's messages in a specific order - PC1,PC2,PC3,PC4,CC1,CC2,PC5. When you assign a CC, you also need to UN-assign the default PC1 or that's what "learn" will "hear".
 
That should solve your problem.
 
Additional note: When sending messages to VSTs, use a different MIDI channel, for instance CH2. That prevents the DAW from reacting inadvertently to a message meant for the VST.


Chris Astles
 

Do you have any way of seeing the raw MIDI messages that are coming into your computer?

For example, in Studio One there is a MIDI button at the bottom which shows the incoming messages.



If you're seeing the expected messages coming through there, but not in your MIDI Learn, then I'd say it's something which needs tweaking in Cubase.

If the wrong messages are coming through there as well, then I'd suggest double-checking the FCB config.


montesarchiopietro@...
 

Also, when I try to send the messages to the editor using the procedure as described in the video, I create the new SysEx (the editor also says "received 4 bytes of data") and read it through the editor itself, but the messages for every PC on the spreadsheet view are always on 1,1,1... I don't know if this problem can be related to the other one


montesarchiopietro@...
 

Thank you very much for the very specific answer. I used midiox to see what it could appear by pressing one-by-one 1,2 and 3 and this was the result:


Now I don't understand much of this, but I assigned (manually) 1 to CC 34, 2 to CC 35 and 3 to CC 36. I don't know if it read it properly. 

About the editor: I tried to change the messages in the spreadsheet and send them to the pedalboard, it seemed it was working (the led on the cable for midi in turned on) but when I checked manually, the PC on the channels were always the same as before. Also in doing the opposite way, sending the messages from the fcb1010 to the editor, it always appeared on the spreadsheet the 1,1,1,1,1... setting.


EJ SHELDON
 

You're looking at Hex Mode.
See attached screenshot to exit hex mode and get more comprehensible results.


ossandust
 

Most probably a MIDI interface problem (very common with those "cable" type interfaces). MIDI-OX shows a lot of corrupt MIDI messages (for valid MIDI the values in column DATA1 and DATA2 should always be lower than 80 hex, so FE, C0, 80, F0, F8, FF are all invalid values)  


montesarchiopietro@...
 

I checked and yes...it seems that the problem was the cable...I connected the fcb1010 with a midi out/in cable to my focusrite scarlett 2i4 and the mapping worked properly on cubase 10.5 (pedal 1 address 1, pedal 2 address 2 and so on). It's still not working with Cubase 5 on my other computer (which is the one that I basically use to work) where the midi learn is still sending everything to address 0, but I think that at this point the software is the other problem, since on another computer and software it's working properly.


David Grosz
 

Your email is confusing but you have to have a value programmed on the switch to auto learn it.  You need to know if your device wants to auto learn a CC or  PC message then program the switch then your device can auto learn


On Mon, Dec 14, 2020 at 3:10 AM, montesarchiopietro@...
<montesarchiopietro@...> wrote:
Hello everyone.
I am new to this group and I'm glad to join this FCB1010 community. I bought my FCB1010 last month, and I'm trying to map it with Cubase 5. The problem is that when I try to do it with the generic remote device control, every time I press a pedal with midi learn it always brings it to "Prog. Change - MIDI Ch. 1 - Address 0", the same for each pedal, even if I set different CCs manually for each preset. Of course sending all the messages to Address 0, the pedalboard doesn't communicate with Cubase and doesn't do the things I want to do (basically for me, mute and unmute the different midi channels). The FCB1010 is linked to the computer with a cable midi in/out - usb. Can you help me with this? Thank you in advance!


montesarchiopietro@...
 

Just to inform everyone that I finally managed to solve my problem. Thank you all, you were fantastic!