Topics

Expression Pedals, Amplitube 4, Reaper 6.19


EJ SHELDON
 

Glad you got it sorted. Rock On!


Tim Brown
 

SOLVED!!
I.D.10-T Error!!

In my PC editor, I had the wrong MIDI input selected.  So none of my preset edits were being uploaded to the FCB!  I changed the MIDI input, trandsmitted the SysEx one more time and viola'!  It works as expected.  Thanks for the tips, though.  I knew I had to be overlooking something minor that was causing it to not send any data.


Tim Brown
 

I think I have it setup how you described.  I exited Reaper and went into the Amplitube standalone version.  My audio input and MIDI input appear set correctly.  When I step on pedal 1, I see the MIDI indicator in the lower right corner of Amp4 flash.  But when I rock Exp B I get nothing.  No flash.
Here's a couple screen shots of what I have going on.  Can you take a look?


EJ SHELDON
 

The following assumes that you are using the stock FCB Chip (not UNO):

The EXP pedals have to be configured in every preset.
You have to select a preset before the pedals become active.

In Amplitube MIDI>Control Change>GLOBAL there's a parameter for WAH. It needs to be set to the CC# that your EXP pedal is sending.
The WAH needs to be turned on using a DIFFERENT CC# assigned to the specific Slot that the WAH is in.

NOTE: the following Global Slot Bypass settings are for AT3/4, NOT AT5.In AT5 the Stomp Slot Bypass needs to be set PER PRESET. PITA!
Support has been notified that this is contrary to what it says in the AT5 manual. HOPEFULLY they'll fix that!
 
ITRW, WAH usually comes first in the signal chain (or after the tuner), so for this example, Slot 1
IF you put the WAH in Stomp A Slot 1
AND assign an FCB button to send CNT1 = CC# (your choice) + Value 0 (ON in AT); CNT2 = SAME CC# + Value = 127 (OFF in AT) to Slot 1
AND assign the EXP A (or B) to a DIFFERENT CC#
AND assign that CC# to the WAH parameter
AND do that in every FCB preset that corresponds to an Amplitube Preset that contains a WAH
THEN the WAH will be ON and the EXP pedal ACTIVE when you press the FCB Button to call the Amplitube Preset, and succesive presses of the button will toggle the WAH ON/OFF.

If you don't want the WAH to be active when you call the Amplitube preset just reverse the CNT1/CNT2 Values (127/0 vs 0/127).

There you go!

Using UNO is SO much easier.....


Tim Brown
 

Hello,
I think I must be overlooking something obvious here but I cannot get my expression pedals to do anything in Reaper. I'd like to set Exp B to be my wah-wah pedal in Amplitube 4. (I'm in the middle of a project, so I haven't upgraded to 5 yet.)  I have Reaper configured correctly (I think)  It sees MIDI input from the switch pedals 1-10, but no input from either rocker pedal.  I double checked the calibration on each expression pedal as I saw suggested in a few other threads while searching, but otherwise I can't get them to do anything.
I was able to get Amplitube to see pedal 1 as a hard high and low setting on the wah. (press once and it sets the wah to 0%, press again and the wah jumps to 100%) so I know I have my tracks configured correctly.  But I'm not sure what to change in my programming to get the expression pedals active. I'm using the Ed Dixon PC editor.  It looks like the pedals are activated in the editor, but zilch when I try to use them in Reaper.
What am I overlooking?