Topics

Studio One Bias FX 2 Assignment


chase.msn99@...
 

Hey y'all. Just starting using Studio One, instead of reaper as my DAW of choice, now I cant seem to get my midi signals through to bias. 

My fcb1010 has eurekaPROM installed, and works great. When I was using Reaper, I used a second track for MIDI inputs, which then were sent to the guitar track/Bias FX.

I cant seem to find how to do that in Studio One.

In Studio One, my board is configured as a MIDI instrument, which in theory should work.

All inputs from my board are being recognized in Studio One's MIDI Monitor. The issue is when I try and assign controls to a footswitch in Bias FX 2, for example, the plugin does not recognize/receive any MIDI inputs or signals. It seems like this is just a simple set up error. Any help would be greatly appreciated!


Jack Fenton
 

Hi,
I think the issue might be when sending CCs in EurekaProm it only send 127 on press and doesn't send anything on release which is common with guitar effects.  I ran into this problem when trying to get EurekaProm to do a sustain function. It would sustain on but never sustain off.  I ended up going to Uno chip.





EJ SHELDON
 

BIAS FX doesn't require toggling CCs, it responds to any value sent on the assigned CC. That's why UNO is basically pointless in terms of having the LEDs track ON/OFF status.
I had a VERY quick look at the S1 manual. It looks like the FCB needs to be set up as a NEW KEYBOARD, then BIAS gets dragged to a blank spot in the ARRANGER view. But that's as far as I got. Presonus gets today's award for AWFUL MIDI documentation. It also could be a problem with the S1 version. IIRC from when I trialed the demo version, some versions don't support MIDI control of VSTs. I could be wrong though, I hated everything about S1. OP - was there a reason that you switched from Reaper? Some feature of S1 that Reaper lacks?


FishOOW
 

Hi there. I’m not sure about Bias, but in S1, when you have the Bias plug-in window open, make sure that your FCB is chosen in the little yellow box in the upper right corner. S1 defaults to your main midi instrument or controller. You have to tie the plug-in with that external midi device through that little box in the corner.
Also, make sure you have setup all the midi message (cc#) info in the external device editor.