FCB1010 Uno with Amplitube


Nala Lee
 

Hello!


I recently purchased a FCB1010 and just installed UNO chip.


I have midi out of FCB connected to midi in of my PC and have been trying to use it with amplitube.


I want to use the stompbox mode to control individual effects on and off.


Could someone guide me with how I can set up the pedal to do so and what software I need to install to make the changes to the pedal?


Thank you!


EJ SHELDON
 

First, get the UNO_ControlCenter Editor:


Read the manual.

Then, open the attached .lgp (ControlCenter sysex) file and download it to your FCB/UNO board.

If you're using Amplitube in standalone mode, you'll want to set the Receive Channel in Amplitube to Channel 1.

This sysex is configured with the STOMP pedals on the bottom row.

Click MIDI (lower right on AT (Amplitube) UI, Click Control Change then Global.
If you're in Bank 00, hit the DOWN pedal once to go to Bank 18.
Highlight PRESET NEXT. Click LEARN. Press Pedal 10.
Highlight PRESET PREVIOUS. Click LEARN. Press Pedal 9.
Highlight VOLUME. Click LEARN. Operate LEFT EXPRESSION PEDAL.
Highlight WAH. Click LEARN. Operate RIGHT EXPRESSION PEDAL.
Highlight WHARMONATOR. Click LEARN. Operate RIGHT EXPRESSION PEDAL.
*NOTE - Typically, you won't have WAH and WHARMONATOR on the same preset.
Highlight TUNER. Click LEARN. Press Pedal 8.

Press UP pedal to return to Bank 00.

Highlight Stomp A Slot 1 Bypass. Click Learn. Press Pedal 1.
Highlight Stomp A Slot 2 Bypass. Click Learn. Press Pedal 2.
Highlight Stomp A Slot 3 Bypass. Click Learn. Press Pedal 3.
Highlight Stomp A Slot 4 Bypass. Click Learn. Press Pedal 4.
Highlight Stomp A Slot 5 Bypass. Click Learn. Press Pedal 5.

Done!

NOTE: The CC#s I'm using are taken from the non-reserved segment of CC#s as specified in the MIDI spec.

Advice: Create a folder called MY PRESETS or something like that. When creating new presets or modifying Factory Presets, always save them to this folder. This way, all your Factory Presets and folders remain pristine.

In order to call Presets, you need to load them into the MIDI/Program Change.panel.

Have Fun!



.


Nala Lee
 

Thank you for the guide and the attachment!  

I will give it a try when I get home!!!


EJ SHELDON
 

BTW - IDK what MIDI interface you're using, but you'll need a 2 way connection to use an editor, and not all interfaces will handle the longer sysex files. If your interface won't connect to the editor, that could be the reason. If it connects but won't DL the sysex to the FCB, there's an option in ControlCenter to send the sysex in smaller chunks that may help.


Nala Lee
 

Right now I only have FCB-Midi Out to PC-Midi In connected and FCB1010 PC Editor shows Firmware: Behringer - Unknown Version.

Thankfully I have an extra Midi cable going to my edrumset, I will use it to connect PC-Midi Out to FCB-Midi In to download the syntax file.

If I have any trouble with the download, I will try the method you mentioned!

Thank you!


EJ SHELDON
 

How are you connected to the computer? Audio Interface with MIDI (brand/model - not all will pass sysex)? Dedicated MIDI Interface (most will pass sysex)? $5 ebay MIDI/USB interface (most will not pass sysex)? This is important.

The Ed Dixon Editor won't work with the UNO Chip - that's why it says "Unknown Version". You NEED the ControlCenter Editor to make this work.


Nala Lee
 

I'm using MIdiman 4X4 to plus my edrum (In Slot A) and FCB (In Slot B) to my PC.

Just noticed the editor program I had installed is not the same as what you described, I was using Behringer FCB1010 MIDI Edit Utility.

I will try with the editor you mentioned and see what happens!

Thank you!


Nala Lee
 

I just did install the editor from your comment, but the control center shows no FCB1010 is connected.

When I tried with the Behringer's editor, it was reading the switches and the pedal before....

Any idea what's causing the Behringer software to work while the control center doesn't?


---In fcb1010_uno@..., <bluesrock13@...> wrote :

How are you connected to the computer? Audio Interface with MIDI (brand/model - not all will pass sysex)? Dedicated MIDI Interface (most will pass sysex)? $5 ebay MIDI/USB interface (most will not pass sysex)? This is important.

The Ed Dixon Editor won't work with the UNO Chip - that's why it says "Unknown Version". You NEED the ControlCenter Editor to make this work.


EJ SHELDON
 

Midiman should work fine. Make sure you've got the latest drivers!


EJ SHELDON
 

Remember when I said READ THE MANUAL? 

DL it from the bottom of the web page where you bought the editor. If you didn't buy it (demo mode) you won't be able to load the sysex to the FCB.

I know you didn't have time to do that yet, SO....

On the menu bar, click setup/select midi ports. Select the MIDIMAN for both ports. Click OK.

On the upper left side of the FCB image you'll see a round DIN connector icon. Click it. That establishes the connection.


Nala Lee
 

I did set the midi in device to my midiman and selected the slot that I had FCB connected and clicked the midi port sign on the editor, but still no luck.

The status bar says 'timed out' and connection status still says it's not connected.

I tried the Behringer Editor again to see if it reads my switches and pedals and it does...

Any idea what's causing this??  Is it because I'm on trial mode???


---In fcb1010_uno@..., <bluesrock13@...> wrote :

Remember when I said READ THE MANUAL? 

DL it from the bottom of the web page where you bought the editor. If you didn't buy it (demo mode) you won't be able to load the sysex to the FCB.

I know you didn't have time to do that yet, SO....

On the menu bar, click setup/select midi ports. Select the MIDIMAN for both ports. Click OK.

On the upper left side of the FCB image you'll see a round DIN connector icon. Click it. That establishes the connection.


EJ SHELDON
 

You need to set both the MIDI IN and MIDI OUT ports, and have both connected.
But, yeah, it's probably because that's the part of the trial that's disabled.
Lots of people use that interface, so no worries about buying the license.


lions@...
 

Hi,


the sysex file is no longer available for download. Could you please upload it again?


Thank you


EJ SHELDON
 

Here ya go!


lions@...
 

Thanks a lot!


Daddy Cool
 

Hmmm, I don't see the attachment!


EJ SHELDON
 

This is an ancient thread. IIRC, the sysex was just the one for using Amplitube with the FCB. Here's the file again. Remember that Amplitube uses ON/OFF values of 0/127 instead of the standard 127/0, so that's how the file is configured. If you want to use the standard (127/0) settings, reverse tose in the sysex. That will, of course, require you to do the same on each and every Amplitube BYPASS setting and, if you're using AT5, since they've done away with the GLOBAL BYPASS settings, you'll need to do that on each and every preset. PITA, but it is what it is.

SYSEX attached.


Daddy Cool
 

Thank you sir!