Date
1 - 4 of 4
ReadOnly Variable $CurrentBankNumber #UnO2
uno@...
Hi,
I just received my UnO2, and it's awesome. Great job. :-) After fiddling with it for a while, I would really love to have access to a Read-Only Variable that returns the current Bank Number, so I could do something like if ($CurrentBankNumber == 2) { ... } Do you think that might make it on the further development backlog? :-D Cheers from Munich, Michael |
|
ossandust
Hi Michael, thanks for the tip, I will add it to the wishlist.
UnO2 offers the possibility for a bank initialization function, so you can easily implement this yourself for now: VAR $CurrentBankNumber = 0
INIT_BANK bank 1 = $CurrentBankNumber = 1
INIT_BANK bank 2 = $CurrentBankNumber = 2
INIT_BANK bank 3 = $CurrentBankNumber = 3
... or if you want to make it more readable: VAR $CurrentBank = ""
INIT_BANK effects = $CurrentBank = "Global effects"
INIT_BANK looper = $CurrentBank = "Looper control"
INIT_BANK presets01 = $CurrentBank = "Preset bank 1" ... |
|
uno@...
Hi - Thank you for the fast help. Yes, INIT_BANK is what I'm also currently using, but there are some actions that I generally want to perform when any bank changes. I can put those into a separate action, of course and call them within INIT_BANK, but as I can not send a parameter to this action it's still a little tedious.
But your suggestion is a good workaround, so this request should probably not make it to the top of your list, unless it's really low effort... :-) |
|
Christopher Masto
It would also be great to be able to have an instruction to set the bank number. Although as I described in my message (https://fcb1010.groups.io/g/uno/message/8323) I only want that as a workaround for not being able to disable banks entirely and treat the bank select as two additional switches. So I hope that's on the wish list. :-) On Sun, Jan 31, 2021 at 5:44 AM <uno@...> wrote: Hi - Thank you for the fast help. Yes, INIT_BANK is what I'm also currently using, but there are some actions that I generally want to perform when any bank changes. I can put those into a separate action, of course and call them within INIT_BANK, but as I can not send a parameter to this action it's still a little tedious. |
|