Portamento CC SWEEP question #UnO2


rcharlier3
 

New #UnO2 user.  My first week with the device.
Midi+synth+keyboard person, not a guitarist.
 
I've made a pedal to turn PORTAMENTO ON or OFF.  That works fine.
When PORTAMENTO is ON, I'm trying to change the sweep pedals 1 and 2 to PortTime and PortAmount.
 
 
 
The "SendMidi" commands work fine, turns Port ON and OFF, the light follows the status, all is good.
SWEEP PortTime = SendMidi chOne CtrlChange 5 0-127
SWEEP PortAmount = SendMidi chOne CtrlChange 84 0-127
 
PRESET pPortamento =
{
   SendMidi chOne CtrlChange 65 127
   Pedal 1 = PortAmount 
   Pedal 2 = PortTime 
}
PRESET_RELEASE pPortamento = SendMidi chOne CtrlChange 65 0
 
 
and then later on in my setup I want to make my power on defaults for the switches to be Foot and Brightness.  That works fine.
 
INIT_FCB = 
{
   Pedal 1 = Foot
   Pedal 2 = Brightness
}
 
When I press the footswitch for Portamento ON/OFF, it does toggle that setting, but my pedals stay as Foot and Brightness and never change to PortAmount and PortTime.
 
What is the simple step that I am missing?


rcharlier3
 

I was able to get this after stepping away for a day and reading more.  This will turn Portamento ON and change the foot switches to CC's 5 and 84.  When the switch is OFF the pedals return to CC's 4 and 74.

EFFECT_ON pPortamento =
{
   SendMidi chOne CtrlChange 65 127
   Pedal 1 = PortAmount 
   Pedal 2 = PortTime 
}
EFFECT_OFF pPortamento =
{
   SendMidi chOne CtrlChange 65 0
   Pedal 1 = Foot
   Pedal 2 = Brightness
}